import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d[0]*\\d{3}([ .-])?\\d{3}([ .-])?\\d{4}|\\d{3}([ .-])?\\d{3}([ .-])?\\d{4}|\\(\\d{3}\\)([ ])?\\d{3}([.-])?\\d{4}|\\(\\d{3}\\)([ ])?\\d{3}([ ])?\\d{4}|\\(\\d{3}\\)([.-])?\\d{3}([.-])?\\d{4}|\\d{3}([ ])?\\d{3}([ .-])?\\d{4}";
final String string = "(123).234.4567\n"
+ "(123)-234-4567\n"
+ "(617) 495-1797\n"
+ "(617) 495 1797\n"
+ "(617) 4951797\n"
+ "6174951797\n"
+ "617 4951797\n\n"
+ "jnnjn 0536 856 9766 jjjkkk\n\n"
+ "123.234.4567\n"
+ "123-456-4567\n"
+ "123.123-1234\n"
+ "123.123-1234\n"
+ "123 123-1234\n"
+ "123 123 1234";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}