const regex = new RegExp('\\d[0]*\\d{3}([ .-])?\\d{3}([ .-])?\\d{4}|\\d{3}([ .-])?\\d{3}([ .-])?\\d{4}|\\(\\d{3}\\)([ ])?\\d{3}([.-])?\\d{4}|\\(\\d{3}\\)([ ])?\\d{3}([ ])?\\d{4}|\\(\\d{3}\\)([.-])?\\d{3}([.-])?\\d{4}|\\d{3}([ ])?\\d{3}([ .-])?\\d{4}', 'gm')
const str = `(123).234.4567
(123)-234-4567
(617) 495-1797
(617) 495 1797
(617) 4951797
6174951797
617 4951797
jnnjn 0536 856 9766 jjjkkk
123.234.4567
123-456-4567
123.123-1234
123.123-1234
123 123-1234
123 123 1234`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);