# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d[0]*\d{3}([ .-])?\d{3}([ .-])?\d{4}|\d{3}([ .-])?\d{3}([ .-])?\d{4}|\(\d{3}\)([ ])?\d{3}([.-])?\d{4}|\(\d{3}\)([ ])?\d{3}([ ])?\d{4}|\(\d{3}\)([.-])?\d{3}([.-])?\d{4}|\d{3}([ ])?\d{3}([ .-])?\d{4}"
test_str = ("(123).234.4567\n"
"(123)-234-4567\n"
"(617) 495-1797\n"
"(617) 495 1797\n"
"(617) 4951797\n"
"6174951797\n"
"617 4951797\n\n"
"jnnjn 0536 856 9766 jjjkkk\n\n"
"123.234.4567\n"
"123-456-4567\n"
"123.123-1234\n"
"123.123-1234\n"
"123 123-1234\n"
"123 123 1234")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.