using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\d+\/\d+\/\d+,\s\d+:\d+:\d+\d+\s\w*\]";
string input = @"[8/23/18, 2:05:50 PM]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}