$re = '/\[\d+\/\d+\/\d+,\s\d+:\d+:\d+\d+\s\w*\]/m';
$str = '[8/23/18, 2:05:50 PM]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);