// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\d+\/\d+\/\d+,\s\d+:\d+:\d+\d+\s\w*\]").unwrap();
let string = "[8/23/18, 2:05:50 PM]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}