#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\+\d+|\(\+?\d+\))?(?:\d{10}| ?\d{3}([ -])\d{3}\1\d{3,4})$"
Local $sString = "(123) 123-123-123" & @CRLF & _
"(+91) 123-123-1234" & @CRLF & _
"1234567890" & @CRLF & _
"123 123 1234" & @CRLF & _
"+92 345 345 3456" & @CRLF & _
"+92 123-123-1234" & @CRLF & _
" - " & @CRLF & _
"" & @CRLF & _
"// No match" & @CRLF & _
"(+91 123-123-1234" & @CRLF & _
"+91) 123-123-1234" & @CRLF & _
"8888888-dfd" & @CRLF & _
"12345678908888" & @CRLF & _
"3434 43434" & @CRLF & _
"123-123 1234" & @CRLF & _
"123 123-1234" & @CRLF & _
"+92 345 345 3456-" & @CRLF & _
"+92 345 345 3456--" & @CRLF & _
"+92 345 345 3456**" & @CRLF & _
"++92 123-123-1234" & @CRLF & _
"+92 123 123-1234" & @CRLF & _
"+++++++" & @CRLF & _
"3" & @CRLF & _
"-+ " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")