using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\+\d+|\(\+?\d+\))?(?:\d{10}| ?\d{3}([ -])\d{3}\1\d{3,4})$";
string input = @"(123) 123-123-123
(+91) 123-123-1234
1234567890
123 123 1234
+92 345 345 3456
+92 123-123-1234
-
// No match
(+91 123-123-1234
+91) 123-123-1234
8888888-dfd
12345678908888
3434 43434
123-123 1234
123 123-1234
+92 345 345 3456-
+92 345 345 3456--
+92 345 345 3456**
++92 123-123-1234
+92 123 123-1234
+++++++
3
-+
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}