import Foundation
let pattern = #"^(?:\+\d+|\(\+?\d+\))?(?:\d{10}| ?\d{3}([ -])\d{3}\1\d{3,4})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(123) 123-123-123
(+91) 123-123-1234
1234567890
123 123 1234
+92 345 345 3456
+92 123-123-1234
-
// No match
(+91 123-123-1234
+91) 123-123-1234
8888888-dfd
12345678908888
3434 43434
123-123 1234
123 123-1234
+92 345 345 3456-
+92 345 345 3456--
+92 345 345 3456**
++92 123-123-1234
+92 123 123-1234
+++++++
3
-+
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)