import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\+\\d+|\\(\\+?\\d+\\))?(?:\\d{10}| ?\\d{3}([ -])\\d{3}\\1\\d{3,4})$";
final String string = "(123) 123-123-123\n"
+ "(+91) 123-123-1234\n"
+ "1234567890\n"
+ "123 123 1234\n"
+ "+92 345 345 3456\n"
+ "+92 123-123-1234\n"
+ " - \n\n"
+ "// No match\n"
+ "(+91 123-123-1234\n"
+ "+91) 123-123-1234\n"
+ "8888888-dfd\n"
+ "12345678908888\n"
+ "3434 43434\n"
+ "123-123 1234\n"
+ "123 123-1234\n"
+ "+92 345 345 3456-\n"
+ "+92 345 345 3456--\n"
+ "+92 345 345 3456**\n"
+ "++92 123-123-1234\n"
+ "+92 123 123-1234\n"
+ "+++++++\n"
+ "3\n"
+ "-+ \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}