package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]-(?:[a-z]{1,10}-){1,2}[0-9]{1,15}\.(?:staging|prod|dev)\.(?:abc\.com)$`)
var str = `s-mimosaserv-1.staging.abc.com
s-mimosa-ser-91.prod.abc.com
s-mimosa-di-97.dev.abc.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}