$re = '/^[a-z]-(?:[a-z]{1,10}-){1,2}[0-9]{1,15}\.(?:staging|prod|dev)\.(?:abc\.com)$/m';
$str = 's-mimosaserv-1.staging.abc.com
s-mimosa-ser-91.prod.abc.com
s-mimosa-di-97.dev.abc.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);