const regex = /^[a-z]-(?:[a-z]{1,10}-){1,2}[0-9]{1,15}\.(?:staging|prod|dev)\.(?:abc\.com)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]-(?:[a-z]{1,10}-){1,2}[0-9]{1,15}\\.(?:staging|prod|dev)\\.(?:abc\\.com)$', 'gm')
const str = `s-mimosaserv-1.staging.abc.com
s-mimosa-ser-91.prod.abc.com
s-mimosa-di-97.dev.abc.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}