re = /^[a-z]-(?:[a-z]{1,10}-){1,2}[0-9]{1,15}\.(?:staging|prod|dev)\.(?:abc\.com)$/m
str = 's-mimosaserv-1.staging.abc.com
s-mimosa-ser-91.prod.abc.com
s-mimosa-di-97.dev.abc.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end