use strict;
my $str = '<table pgwide="0" id="dvr_config_firmware>
<title>DFR Firmware</title>
<tgroup cols="2">
<colspec colname="col1>
<colspec colname="col2">';
my $regex = qr/=(?:(")([^"<>\s]*)()(?=[\s>]|\/>)|(?!")()([^"<>\s]*)("))/p;
my $subst = '="\\2\\5"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";