import re
regex = re.compile(r'=(?:(")([^"<>\s]*)()(?=[\s>]|\/>)|(?!")()([^"<>\s]*)("))')
test_str = ("<table pgwide=\"0\" id=\"dvr_config_firmware>\n"
"<title>DFR Firmware</title>\n"
"<tgroup cols=\"2\">\n"
"<colspec colname=\"col1>\n"
"<colspec colname=\"col2\">")
subst = "=\"\\2\\5\""
result = regex.sub(subst, test_str)
if result:
print(result)