#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\*|\G(?<!^)")[^*"]*"\K[^*"]*(?=".*\*)|(\*[^*]*\*|\G(?<!^)"[^"*]*\*)(*SKIP)(*F)"
Local $sString = "*test1 "test2" test3 "test4"* *test5* "test6" *"test7"*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")