const regex = /(?:\*|\G(?<!^)")[^*"]*"\K[^*"]*(?=".*\*)|(\*[^*]*\*|\G(?<!^)"[^"*]*\*)(*SKIP)(*F)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\*|\\G(?<!^)")[^*"]*"\\K[^*"]*(?=".*\\*)|(\\*[^*]*\\*|\\G(?<!^)"[^"*]*\\*)(*SKIP)(*F)', 'g')
const str = `*test1 "test2" test3 "test4"* *test5* "test6" *"test7"*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}