import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\*|\\G(?<!^)\")[^*\"]*\"\\K[^*\"]*(?=\".*\\*)|(\\*[^*]*\\*|\\G(?<!^)\"[^\"*]*\\*)(*SKIP)(*F)";
final String string = "*test1 \"test2\" test3 \"test4\"* *test5* \"test6\" *\"test7\"*";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}