re = /(?:\*|\G(?<!^)")[^*"]*"\K[^*"]*(?=".*\*)|(\*[^*]*\*|\G(?<!^)"[^"*]*\*)(*SKIP)(*F)/
str = '*test1 "test2" test3 "test4"* *test5* "test6" *"test7"*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end