package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`
(?:\G(?!^)|\b(?=(?:STREET|AVENUE|BOULEVARD)\b))[A-Z]*?\K(?:TREE|E(?:NU)?|OU|AR)\B`)
var str = `STREET|AVENUE|BOULEVARD`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}