re = /
(?:\G(?!^)|\b(?=(?:STREET|AVENUE|BOULEVARD)\b))[A-Z]*?\K(?:TREE|E(?:NU)?|OU|AR)\B/x
str = 'STREET|AVENUE|BOULEVARD'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result