import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\n"
+ "(?:\\G(?!^)|\\b(?=(?:STREET|AVENUE|BOULEVARD)\\b))[A-Z]*?\\K(?:TREE|E(?:NU)?|OU|AR)\\B";
final String string = "STREET|AVENUE|BOULEVARD";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}