$re = '/
(?:\G(?!^)|\b(?=(?:STREET|AVENUE|BOULEVARD)\b))[A-Z]*?\K(?:TREE|E(?:NU)?|OU|AR)\B/x';
$str = 'STREET|AVENUE|BOULEVARD';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;