using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!\b(bobo|cu|porra|Pinto)\b).)+$";
string input = @"bobo
boboteste
cuca
cu
caracu
tomar no cu
cu doce
o cu da sua mae
que porra é essa
porrada
porra
João Pinto
Pintor";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}