const regex = /(?<protocol>[a-zA-Z-]+)\:\/\/(?:(?<credentials>[a-zA-Z0-9-_:]+)\@)?(?<hostPort>(?<host>[a-zA-Z0-9.]+)(?:\:(?<port>[0-9]+))?)(?<pathParameter>(?:\/(?<path>[a-zA-Z\/]*))?(?:\?(?<parameter>[a-zA-Z0-9=&%.]+))?)?(?:\#?(?<name>[a-zA-Z\-_0-9]+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<protocol>[a-zA-Z-]+)\\:\\\/\\\/(?:(?<credentials>[a-zA-Z0-9-_:]+)\\@)?(?<hostPort>(?<host>[a-zA-Z0-9.]+)(?:\\:(?<port>[0-9]+))?)(?<pathParameter>(?:\\\/(?<path>[a-zA-Z\\\/]*))?(?:\\?(?<parameter>[a-zA-Z0-9=&%.]+))?)?(?:\\#?(?<name>[a-zA-Z\\-_0-9]+))?', 'gm')
const str = `
ssh://username:password@google.com:22
ssh-tls://username:password@google.com:443?udpgw=7302&sni=myserver.org#myConfigName
ssh-tls://username:password@google.com:443?udpgw=7302#myConfigName
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}