$re = '/(?<protocol>[a-zA-Z-]+)\:\/\/(?:(?<credentials>[a-zA-Z0-9-_:]+)\@)?(?<hostPort>(?<host>[a-zA-Z0-9.]+)(?:\:(?<port>[0-9]+))?)(?<pathParameter>(?:\/(?<path>[a-zA-Z\/]*))?(?:\?(?<parameter>[a-zA-Z0-9=&%.]+))?)?(?:\#?(?<name>[a-zA-Z\-_0-9]+))?/m';
$str = '
ssh://username:password@google.com:22
ssh-tls://username:password@google.com:443?udpgw=7302&sni=myserver.org#myConfigName
ssh-tls://username:password@google.com:443?udpgw=7302#myConfigName
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);