import re
regex = re.compile(r"(?<protocol>[a-zA-Z-]+)\:\/\/(?:(?<credentials>[a-zA-Z0-9-_:]+)\@)?(?<hostPort>(?<host>[a-zA-Z0-9.]+)(?:\:(?<port>[0-9]+))?)(?<pathParameter>(?:\/(?<path>[a-zA-Z\/]*))?(?:\?(?<parameter>[a-zA-Z0-9=&%.]+))?)?(?:\#?(?<name>[a-zA-Z\-_0-9]+))?", flags=re.MULTILINE)
test_str = ("\n"
"ssh://username:password@google.com:22\n\n\n"
"ssh-tls://username:password@google.com:443?udpgw=7302&sni=myserver.org#myConfigName\n\n"
"ssh-tls://username:password@google.com:443?udpgw=7302#myConfigName\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")