// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<protocol>[a-zA-Z-]+)\:\/\/(?:(?<credentials>[a-zA-Z0-9-_:]+)\@)?(?<hostPort>(?<host>[a-zA-Z0-9.]+)(?:\:(?<port>[0-9]+))?)(?<pathParameter>(?:\/(?<path>[a-zA-Z\/]*))?(?:\?(?<parameter>[a-zA-Z0-9=&%.]+))?)?(?:\#?(?<name>[a-zA-Z\-_0-9]+))?").unwrap();
let string = "
ssh://username:password@google.com:22
ssh-tls://username:password@google.com:443?udpgw=7302&sni=myserver.org#myConfigName
ssh-tls://username:password@google.com:443?udpgw=7302#myConfigName
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}