#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=\b\d{8}\b)(?:(?:9?8?7?6?5?4?3?2?1?0?)|(?:0?1?2?3?4?5?6?7?8?9?))(?<=\d{8})"
Local $sString = "This regex is to match Ascending or descending order of 8 digit number" & @CRLF & _
"01234567 0 to 7" & @CRLF & _
"12345678 1 to 8" & @CRLF & _
"23456789 2 to 9" & @CRLF & _
"12456789 missing 3" & @CRLF & _
"01236789 missing 4,5" & @CRLF & _
"23456789 missing 0,1" & @CRLF & _
"1234567" & @CRLF & _
"12345" & @CRLF & _
"012345678" & @CRLF & _
"123456789" & @CRLF & _
"0123456789" & @CRLF & _
"98765432 9 to 2" & @CRLF & _
"87654321 8 to 1" & @CRLF & _
"76543210 7 to 0" & @CRLF & _
"98765321 missing 4" & @CRLF & _
"96543210 missing 7,8" & @CRLF & _
"98765432 missing 0,1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")