import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:accounts)?(?:(?:,|^)leads)?(?:(?:,|^)contacts)?(?:(?:,|^)opportunities)?$";
final String string = "accounts,leads,contacts,opportunities\n\n"
+ "accounts,opportunities\n"
+ "leads,opportunities\n\n"
+ "leads,accounts,contacts\n"
+ "accounts,leads,contacts,\n"
+ ",accounts,leads,contacts\n"
+ "apples,bananas,contacts";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}