$re = '/^(?:accounts)?(?:(?:,|^)leads)?(?:(?:,|^)contacts)?(?:(?:,|^)opportunities)?$/m';
$str = 'accounts,leads,contacts,opportunities
accounts,opportunities
leads,opportunities
leads,accounts,contacts
accounts,leads,contacts,
,accounts,leads,contacts
apples,bananas,contacts';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);