// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:accounts)?(?:(?:,|^)leads)?(?:(?:,|^)contacts)?(?:(?:,|^)opportunities)?$").unwrap();
let string = "accounts,leads,contacts,opportunities
accounts,opportunities
leads,opportunities
leads,accounts,contacts
accounts,leads,contacts,
,accounts,leads,contacts
apples,bananas,contacts";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}