re = /^(?:accounts)?(?:(?:,|^)leads)?(?:(?:,|^)contacts)?(?:(?:,|^)opportunities)?$/m
str = 'accounts,leads,contacts,opportunities
accounts,opportunities
leads,opportunities
leads,accounts,contacts
accounts,leads,contacts,
,accounts,leads,contacts
apples,bananas,contacts'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end