using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\*\*)\bMUST\b( NOT\b)?(?!\*\*)";
string substitution = @"**MUST\1**";
string input = @"MUST NOT - **MUST NOT** - MUST - **MUST**";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}