import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\*\\*)\\bMUST\\b( NOT\\b)?(?!\\*\\*)";
final String string = "MUST NOT - **MUST NOT** - MUST - **MUST**";
final String subst = "**MUST\\1**";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}