const regex = new RegExp('(?<!\\*\\*)\\bMUST\\b( NOT\\b)?(?!\\*\\*)', 'gm')
const str = `MUST NOT - **MUST NOT** - MUST - **MUST**`;
const subst = `**MUST\1**`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);