#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<![\*\[\]])\bbegin\b(?![\*\[\]])"
Local $sString = ",Begin " & @CRLF & _
", Begin " & @CRLF & _
",Begin," & @CRLF & _
"Begin," & @CRLF & _
",*begin" & @CRLF & _
",*begin*" & @CRLF & _
",begin*" & @CRLF & _
",begin[" & @CRLF & _
",begin]" & @CRLF & _
"asbeginasd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")