$re = '/(?<![\*\[\]])\bbegin\b(?![\*\[\]])/mi';
$str = ',Begin
, Begin
,Begin,
Begin,
,*begin
,*begin*
,begin*
,begin[
,begin]
asbeginasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);