re = /(?<![\*\[\]])\bbegin\b(?![\*\[\]])/mi
str = ',Begin
, Begin
,Begin,
Begin,
,*begin
,*begin*
,begin*
,begin[
,begin]
asbeginasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end