import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\*\\[\\]])\\bbegin\\b(?![\\*\\[\\]])";
final String string = ",Begin \n"
+ ", Begin \n"
+ ",Begin,\n"
+ "Begin,\n"
+ ",*begin\n"
+ ",*begin*\n"
+ ",begin*\n"
+ ",begin[\n"
+ ",begin]\n"
+ "asbeginasd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}