use strict;
my $str = 'Alonso (2000) El papel del lenguaje interior en la regulación del comportamiento
Azcoaga (1988) El papel del lenguaje interno en el proceso de conocimiento
Caramazza (1989) On drawing inferences about the Structure of Normal Cognitive Sysytems';
my $regex = qr/(?<=\)\s).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}