package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^\w+\s)|(\d\?\(\w+\)\s)|(?:\d+\?$)`)
var str = `3A 4?(1) 5?(2) 6?(a) 7?(4) 8?(a) 9?(ii) 10?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}