re = /(?:^\w+\s)|(\d\?\(\w+\)\s)|(?:\d+\?$)/m
str = '3A 4?(1) 5?(2) 6?(a) 7?(4) 8?(a) 9?(ii) 10?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end