// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^\w+\s)|(\d\?\(\w+\)\s)|(?:\d+\?$)").unwrap();
let string = "3A 4?(1) 5?(2) 6?(a) 7?(4) 8?(a) 9?(ii) 10?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}