#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*?(meta:.*").*"
Local $sString = "<asp:Button ID="id1" runat="server" meta:resourceKey="ButtonTxt"/>" & @CRLF & _
"<asp:Label ID="id2" runat="server" meta:resourceKey="Name"></asp:Label>" & @CRLF & _
"<asp:Label ID="id3" runat="server" meta:resourcekey="Other_Name"></asp:Label>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")