using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?(meta:.*"").*";
string input = @"<asp:Button ID=""id1"" runat=""server"" meta:resourceKey=""ButtonTxt""/>
<asp:Label ID=""id2"" runat=""server"" meta:resourceKey=""Name""></asp:Label>
<asp:Label ID=""id3"" runat=""server"" meta:resourcekey=""Other_Name""></asp:Label>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}