$re = '/.*?(meta:.*").*/m';
$str = '<asp:Button ID="id1" runat="server" meta:resourceKey="ButtonTxt"/>
<asp:Label ID="id2" runat="server" meta:resourceKey="Name"></asp:Label>
<asp:Label ID="id3" runat="server" meta:resourcekey="Other_Name"></asp:Label>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);