# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\-)\[.+?\](\.\w{3}$)/\1/gmi;t' <<< "SampleFileA-[SortCode].xls
SampleFileB-[SortCode][CRCNum].xls
SampleFileC-[SortCode][OtherSortCode][CRCNum].xls
SampleFileD-Date[CRCNum].xls
SampleFileE-Date.xls
In this example I only want to remove [CRCNum] from the file names.
This is as close as I can get. I just don't know how to use lookbehind properly"