$re = '/(?<!\-)\[.+?\](\.\w{3}$)/mi';
$str = 'SampleFileA-[SortCode].xls
SampleFileB-[SortCode][CRCNum].xls
SampleFileC-[SortCode][OtherSortCode][CRCNum].xls
SampleFileD-Date[CRCNum].xls
SampleFileE-Date.xls
In this example I only want to remove [CRCNum] from the file names.
This is as close as I can get. I just don\'t know how to use lookbehind properly';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;